whmcs的nginx伪静态规则

  location ~ /(announcements|knowledgebase|download|store|password|cart|account|subscription)(.*) { rewrite (.*) /index.php; }
  location ~ /(.*)/(addons|apps|search|domains|help|services|setup|utilities|clients)(.*) { rewrite (.*) /admin/index.php;}

方案一:

if (!-f $request_filename){ rewrite (.*) /index.php;  }

方案二:

 rewrite ^/(announcements|knowledgebase|download|store|password|cart|account|subscription)(.*)$ /index.php;

其他设置:

  location ~* \.(tpl|inc|cfg)$ {  deny all; }
  location ^~ /vendor/ { deny all; }


方案一主要匹配本地没有的就丢index.php上去,  也可以用try_files

方案二主要是直接进行rewrite.


其他配置主要是隐藏一些目录和文件不让访问.


 总的来说用 location来匹配稍微稳妥一些, 例如 /admin/clientsservices.php 会被为静态匹配到, 还是得运用if来判断匹配.

影视类小站的一些特征

     首先, 近些年的版权投诉越来越完善, 以前中文内容基本很少有版权投诉.

从英文到韩日资源再到中文的资源, 逐渐的中文资源的投诉越来越多, 英文等外语类的投诉相对较少了很多.


因为版权的原因, 一有投诉有的人积极处理有的人装死跑路换一家主机商,反正市面上成群结队的主机供应商可以选, 都是东躲西藏的心态, 长期以往后形成了一种拔屌无情的形态.

常见的一些特征:  大部分技术比较菜知识储备少, 被入侵或者注入只能哭; 还保持着10多年前的只会采集外链模式 ;对于版权投诉部分人呈现出暴躁的状态, 对网络资源开销较大, 类似和次于早期开飞机场的.


经验总结: 

   总体来说这部分人有一定不错的营收, 喜欢套近乎获取一些技术支持,获取一些优势价格以及对版权投诉宽裕处理,  比较注重所失不注重所得.  不论提供多优势多有利条件都会随时扭头翻脸.

不建议提供太多的技术支持,资源支持等等, 在成本资源和人力资源方面超支的该收钱必须得收, 没有让步的必要.

对于版权投诉该处理就处理不要嫌麻烦, 投诉量大又不处理的完全没有留的必要, 趁早清退免于问题扩大.


10G光模块中SR, LR, LRM, ER 和 ZR的区别

SR、LR、ER、ZR常用于SFP+和XFP封装的模块.指的是传输距离,SR是短距离,通常几百米以内.LR10KM,ER40KM,ZR80KM

产品类型传输距离中心波长接口工作温度DDM
SFP-10G-SR300m852nmDuplex LC0-70℃D
SFP-10G-LRM220m1310nmDuplex LC0-70℃D
SFP-10G-LR10km1310nmDuplex LC0-70℃D
SFP-10G-ER40km1550nmDuplex LC0-70℃D
SFP-10G-ZR70km-80km1550nmDuplex LC0-70℃D


nginx正向代理

server {  
    listen 8080;  
    resolver 114.114.114.114; 
    location / {  
        proxy_pass $scheme://$http_host$request_uri;
        proxy_set_header HOST $http_host;
        proxy_buffers 256 4k;
        proxy_max_temp_file_size 0k; 
        proxy_connect_timeout 30;
        proxy_send_timeout 60;
        proxy_read_timeout 60;
        proxy_next_upstream error timeout invalid_header http_502;
    }  
deny 127.0.0.1;
}


大约2012年的一台E3服务器价格记录

CPU: E3-1230V3 - RMB¥1380

主版 Supermicro X10SLH-F - RMB¥1300

內存 三星8GB UDIMM * 4 - RMB¥[email protected]

RAID 卡: LSI 9261-8i + BBU - RMB¥1200

硬盤: 西數1TB 黑色 * 4 - RMB¥1960

機箱, 散熱, 電源, 導軌 - RMB¥900


一共8740元

奇怪的安装脚本之一

wget https://minecraft.azureedge.net/bin-linux/bedrock-server-1.10.0.7.zip
unzip bedrock-server-1.10.0.7.zip
apt
apt install zip
unzip bedrock-server-1.10.0.7.zip
LD_LIBRARY_PATH=. ./bedrock_server


nginx php.conf配置

location ~ .*\.(php)?$ {
        try_files $uri = 404;
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass  unix:/dev/shm/php-cgi.sock;
        fastcgi_index index.php;
        fastcgi_param SCRIPT_FILENAME $document_root/$fastcgi_script_name;
        include fastcgi_params;
        }
location ~ .*\.(htm|gif|jpg|jpeg|png|bmp|ico|flv|swf|txt|wma)$ { expires  30d;}
location ~ .*\.(js|css)?$ { expires   1d;}
location ~ .*\.(tpl|svn|asp|aspx|jsp|do|mdb|zip|rar|bak|htc)?${ deny all; }
location ~ /0.* { deny all; }
if (!-e $request_filename) { return 444; }


关于LVM丢分区和丢数据(最近又又又发生了)

LVM在linux下灵活划分硬盘空间分区是非常好用的一个东西.

从centos5开始到现在还在用的centos7, 我一直都在和lvm做斗争.

问题其实也简单, 无非就是lv分区导致丢失: 分区的md编号错乱丢失lv, lvremove恢复后丢失lv, 以及还有许多已经忘记的原因.


上月由于机柜搬迁数据中心的问题,  一些宿主服务器子系统较多关机时间太长, 在半路进行了强制关机.

然而在恢复完后就发现一些子系统没有恢复, 由于标签显示是自用的节点又暂时没有时间就延后处理了.

今天清点后发现全是自用的节点, 好在都是非一线重要的东西.


7月底一台快7年的E3 4x1T RAID10的服务器硬盘挂掉导致whmcs数据丢失了一部分重要的数据, 

又因为之前迁移进来后没有做定时数据备份, 好在抢救到的数据能维持正常运行, 覆盖早先的备份后一切正常,

此事算妥善处理完成了.


丢数据的事其实已经亲身遇上过很多次了, 硬盘坏掉和LVM丢分区的事每年都有遇上, 即使有RAID也会翻车的可能.

从第一次在webnx的RAID10挂掉, 到LVM串联硬盘分区, 再到rm -rf 数据库, 以及这次又是RAID的挂掉.


数据备份不能马虎, 一定要做, 且异地备份 本地备份 差异备份 同步备份 都要做上, 数据越重要就越需要做备份.


有2次丢掉财务数据库经验的我总结的经验是, 不是每次都那么幸运可以靠手动修复数据.

有时候没了就是没了, 说啥都没有用.

ST、SC、FC、LC光纤头

日常记录

sflow

Juniper sflow配置:

set protocols sflow agent-id {agent IP地址}
set protocols sflow polling-interval 30
set protocols sflow sample-rate ingress 3000
set protocols sflow sample-rate egress 3000
set protocols sflow collector {接受数据的IP}
set protocols sflow interfaces {ge-0/1/1.0 指定端口} 

H3C sflow配置:

sflow agent ip 10.193.1.1  !设置此设备的某端口地址为agent地址
 sflow source ip 10.193.1.1 !设置此设备的某端口地址为发送源地址
 sflow collector 1 vpn-instance mgmt ip 10.5.0.208 !设置collector1服务器地址,端口号默认6343
 
int te1/0/0/7 !进入需要采集的接口
 sflow flow collector 1 !与collector 1 绑定
 sflow sampling-rate 1000 !设置采样率
 sflow counter collector 1 !计数器绑定collector1
 sflow counter interval 60 !计数器间隔60s
!

Cisco Netflow设置

flow record yst  !配置netflow记录器yst
 match ipv4 source address !记录内容ipv4源地址
 match ipv4 destination address !记录目标地址
 collect counter bytes !计数器单位bytes
 collect counter packets !计数器单位packets
!
!
flow exporter yst !配置netflow输出器
 destination 10.5.0.208 !设置服务器地址
 source TenGigabitEthernet0/0/0 !设置发包源地址
 dscp 63 !设置qos dscp
 ttl 15 !设置ttl
 transport udp 6343 !配置端口号
 export-protocol netflow-v5 !配置版本为v5,各版本区别百度
 template data timeout 30 超时时间30
!
!
flow monitor yst !设置监视器yst
 exporter yst !绑定输出器yst
 record yst !绑定记录器yst

int gi1/0/1 !开启接口flow
ip flow monitor yst input
ip flow monitor yst output

bird+juniper BGP RTBH

bird实例

log syslog all;
debug protocols off;
debug commands 0;

router id 1.1.1.1;

protocol static rtbh {
	route 99.99.99.99/32 blackhole;
	route 88.88.88.88/32 blackhole;
}

filter export_rtbh_out {
	# Limit to static routes
	if (proto = "rtbh") then
	{
		# Limit to /32 host routes (for now)
		if net.len = 32 then
		{
			bgp_community.add((65001,9999));
			bgp_next_hop = 192.0.2.1;
			accept;
		}
	}
	reject;
}

protocol bgp ER3 {
	description "iBGP to Edge Router 3 for RTBH";
	debug { states, events };
	local 1.1.1.1 as 65001;
	neighbor 3.3.3.3 as 65001;
	import none;
	export filter export_rtbh_out;
}
protocol bgp ER4 {
	description "iBGP to Edge Router 4 for RTBH";
	debug { states, events };
	local 1.1.1.1 as 65001;
	neighbor 4.4.4.4 as 65001;
	import none;
	export filter export_rtbh_out;
}



JUNOS 配置实例

routing-options {
	static {
		route 192.0.2.1/32 discard;
	}
}

protocols {
	bgp {
		group RTBH {
			type internal;
			import import-from-rs;
			expor deny-all;
			neighbor 1.1.1.1;
		}
	}
}

policy-options {
	policy-statement deny-all {
		term 1 {
			then reject;
		}
	}
	policy-statement import-from-rs {
		term 1 {
			from {
				community RTBH;
				route-filter 0.0.0.0/0 prefix-length-range /32-/32;
			}
			then accept;
		}
		term reject {
			then reject;
		}
	}
	community RTBH members 65001:9999;
}

抄录自https://gist.github.com/floatingstatic/854aa504a92ab8bc3e044e434ec378c4

手掌脱皮手指干裂

又是一年秋季,有些人手的手掌脱皮,指尖脱皮龟裂且裂口出外翻。

如果只是脱皮其实还好,也就手掌的掌纹变白皮肤犹如枯枝扎人,但是如果指尖脱皮又开裂,就生不如死没,一是痛二是指尖的触觉犹如覆盖了一层502胶水。

我的解决办法是在发现贴创口贴的地方皮肤明显更加湿润和热水泡胀手脚皮肤去角质层想到的,然后跑药店买了几幅医用手套,
在睡前洗涂抹新鲜的肉芦荟(用护手霜或甘油也可以)再戴手套睡觉,反复折腾几天后皮肤就恢复了正常机能。

如果情况严重的建议先去医院断诊。

阅读剩余部分...

加班文化

早些年(新千年之前), 一群人下岗创业, 长三角和珠三角蒸蒸日上, 内陆的乡镇企业逐渐因为产业
升级开始没落, 内陆乡镇的人开始外出到沿海打工.

这些人的相同点, 没什么钱/背井离乡.

阅读剩余部分...